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5.2.6. Le Modificateur Build  
Mode : Tous les Modes – Panneau : Contexte Edit > Panneau Modifiers – Raccourci : F9. 
 
Le Modificateur Build  fait que les faces de l'Objet apparaissent, l'une après l'autre, selon un décompte de temps comme si 
l'Objet se "construisait" petit à petit devant nous. Si le matériau du Maillage est un matériau Halo, plutôt qu'un matériau 
standard, alors ce sont les vertices du Maillage, et pas les faces, qui apparaissent l'un après l'autre.  
Les faces (ou les vertices) apparaissent dans l'ordre dans lequel ils sont stockés en mémoire. Cet ordre peut être modifié en 
sélectionnant l'Objet et en pressant CTRL F  hors du mode Edit  pour trier les faces en se basant sur la hauteur de leur axe local 
Z. 
 

• Start : Le cellos de départ du processus de construction.  
• Length : Le nombre de cellos à utiliser pour la construction, à régler 

entre 0% et 100%.  
• Randomize : Rend aléatoire l'ordre selon lequel sont construites les 

faces.  
• Seed : La semence aléatoire. Modifiez cette valeur pour obtenir une 

répartition aléatoire différente (mais déterministe). 
 

 

Exemple : 

 
 

Imaginez une ville qui se construise devant vos yeux. Cet exemple montre un simple tube, subdivisé un certain nombre de fois, 
avec le Modificateur Build  activé, entre le cellos 1 et le cellos 100 (par étapes de 10) sans animation supplémentaire.  
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5.2.7. Le Modificateur Armature 
Mode : Tous les Modes – Panneau : Contexte Edit > Panneau Modifiers – Raccourci : F9. 
 

Le Modificateur Armature  est utilisé pour construire systèmes de Bones (squelettes) pour animer les poses de personnages et 
toute chose qui nécessite d'être mise en poses. En ajoutant un système Armature  à un Objet, cet Objet peut être déformé avec 
précision de sorte que la géométrie n'a pas besoin d'être animée à la main. Le Modificateur Armature  permet à des Objets 
d'être déformé par des Bones, simplement en spécifiant le nom de l'Objet Armature . 
 
• OB: : Le nom de l'Objet auquel sera appliqué ce Modificateur Armature .  
• Vert.Groups : Active/désactive les groupes de vertices définissant la 

déformation.  
• Envelopes : Active/désactive les enveloppes des Bones définissant la 

déformation.  
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5.2.8. Le Modificateur Hook  
Les Hooks sont similaires aux Clés Shapes en ce sens qu'ils déforment un Maillage en fonction du temps (cellos). La 
différence est que les Hooks déplacent les vertices sélectionnés sous l'influence d'un Empty, et que vous faites bouger un 
Hook en animant le mouvement d'un Empty via une courbe IPO (et des images-clés).  
 

5.2.8.1. Les Objets Hooks (Object Hooks)  
Mode : Mode Object / Mode Edit – Panneau : contexte Edit > Panneau Modifiers – Raccourci : CTRL H  – Menu : 
Mesh>Vertices>Add Hook.  
 

Les Hooks (crochets de manipulation de maillage) donnent accès au niveau Object à la géométrie sous-jacente des Maillages, 
Courbes, Surfaces et Lattices. Un Hook est une caractéristique d’Objet, et est équivalent au parent d’un Objet, mais pour des 
vertices. Vous pouvez créer autant de Hooks pour un Objet que vous le voulez, et vous assignez à chaque Hook les vertices 
qui seront affectés. Des Hooks qui se recoupent sont aussi possibles, car un facteur de pondération par Hook est fourni qui 
détermine de quelle quantité chaque Hook affectera les vertices recouverts. 
 

Notez que ce système ne fonctionne pas avec les groupes de vertices (Vertex Groups) d’un maillage, mais procure à la place 
une méthode générique pour tous les types d’Objets. Un Hook stocke des références vers les indices de vertices, ce qui 
implique que quand vous avez complètement remodelé quelque chose,. 
 

Toutes les options et transformations de niveau Objet sont possible sur l'Objet Hook, en incluant l'utilisation des hiérarchies, 
des contraintes, des courbes IPO et des animations par chemin (path). Vous pouvez aussi rendre l'Objet Hook parent, enfant de 
l'Objet original, si vous ne voulez pas que les transformations de l'Objet ne déformes les Hooks..  
 

Note : Quand vous modifiez la topologie (par exemple, avec une édition plus destructrice que simplement manipuler les 
vertices existants) vous devrez généralement réassigner les Hooks existants.  

 

Exemple 
Un exemple typique d'utilisation des Hooks est l'animation de vertices (ou de groupes de vertices). Par exemple, vous pouvez 
vouloir animer les vertices associés à la "Bouche" du visage d'un personnage.  
 

Dans les images ci-dessous (visage animé : cellos 1 à gauche, et cellos 10 à droite), un visage constitué de courbes de Bézier 
s'est vu appliquer deux Hooks. L'un est appliqué au point de contrôle sur la bouche appelé A et l'autre est appliqué sur le point 
de contrôle du sourcil appelé B. L'animation a 10 cellos pendant lesquels le Hook A se déplace vers le haut et le Hook B vers 
le bas.  
 

  
 

5.2.8.2. Ajouter des Hooks (Adding Hooks) 
Mode : Mode Edit  - Panneau : contexte Edit > Panneau Modifiers – Raccourci : CTRL H  – Menu : Mesh>Vertices>Add 
Hook.  

 

Comme les Hooks sont en relation avec les vertices (ou points de contrôle), la plupart des 
options d'édition sont disponibles en mode Edit  sur les Maillages, les Courbes, les Surfaces 
et les Lattices. 
 

En mode Edit , sélectionnez les vertices et appelez le menu Hooks à l'aide de CTRL H . 
 
• Add, New Empty : Permet d’ajouter un Hook et de créer un Objet Empty, qui sera le 

parent de la sélection au centre de la sélection. 
• Add, To Selected Object : Quand un autre Objet est sélectionné (vous pouvez faire 

cela en mode Edit avec CTRL RMB ), le nouveau Hook est créé et parenté à cet Objet.  
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5.2.8.3. Editer des Hooks (Editing Hooks) 
Mode : Mode Edit  – Panneau : contexte Edit > Panneau Modifiers – Raccourci : CTRL H  – Menu : Mesh>Vertices>Add 
Hook.  
 

Une fois que des Hooks sont disponible dans un Objet,  le menu Hooks accessible avec CTRL H , 
offre des options supplémentaires : 
 

• Remove ... : Permet d’ouvrir un nouveau menu avec une liste des Hooks pouvant être supprimés. 
• Reassign ... : Utilisez cette option si vous voulez assigner de nouveaux vertices à un Hook 

existant. 
• Select ... : Permet de sélectionner les vertices attachés à un Hook spécifique. 
• Clear Offset ... : Permet de neutraliser la transformation en cours d’un parent de Hook. 
 

 

5.2.8.4. Le Modificateur Hook (Hook Modifier) 
Mode : Mode Object / mode Edit – Panneau : contexte Edit > Panneau Modifiers – Raccourci : CTRL H .   
 

Les Hooks sont des Modificateurs qui sont ajoutés à la pile des Modificateurs. Vous pouvez donner un nouveau nom à chaque 
Modificateur Hook (le nom par défaut est le nom du parent), lui donner un nouveau parent en entrant directement son nom ou 
lui assigner un facteur de pondération Force:.  

 

• Ob: : L'Objet parent du Hook (exécute aussi un Reset – voir ci-dessous).  
• Reset : Recalcule (et efface le décalage de) la transformation du Hook. 
• Recenter : Ajuste le centre du Hook sur la position du curseur. 
• Select : Sélectionne les vertices affectés sur le Maillage.  
• Reassign : Réassigne les vertices sélectionnés à ce Hook. 
• Force: : Comme plusieurs Modificateur Hook peuvent agir sur les même 

vertices, vous pouvez pondérer l’influence d’un Modificateur Hook de cette 
façon. Les règles de pondération sont : 

 

− Si le total de toutes les forces est inférieur à 1.0, le reliquat (1.0 – forces) sera le facteur que la position originale 
aura comme force.  

− Si le total de toutes les forces est supérieur à 1.0, elle n’utilisera que les transformations des Hooks,  moyennée par 
leurs pondérations.  

• Falloff: : Si différent de 0, le Fallof correspond à la distance où l’influence du Hook est égale à 0. Il utilise une 
interpolation lissée comme les outils d'Edition Proportionnelle.  
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5.2.9. Le Modificateur Curve  
 

5.2.9.1. L’Outil Taper  
L’outil Taper est un outil de retaillage dont l’effet est contrôlé par un Objet Curve. L'outil est utilisé sur des Objets biseautés 
ou extrudés. Comme pour l'extrusion, "l'effilage" (Tapering) est "activé" en entrant le nom de l'Objet Curve dans le champ 
TaperOb: du panneau Curve and Surface.  
 

L'Objet Taper Curve définit la largeur de l'extrusion le long de la courbe sur l'Objet 'Biseauté' qui est défini dans le champ 
BevOb:. L'Objet Taper Curve est typiquement horizontal, et la hauteur (la coordonnée locale Y) indique l'échelle (scale) qui 
est appliquée. Si un point sur l'Objet Taper Curve va au-dessus de 0, sur l'axe local Y, un agrandissement intervient. Si un 
point sur l'Objet Taper Curve va au-dessous de 0, alors un rétrécissement intervient. Imaginez que vous modifiez le volume 
de l'Objet biseauté avec l'Objet Taper Curve.  
 

Par exemple, nous pouvons 'effiler' (taper) l'Objet extrudé de l'exemple ci-dessous en utilisant un Objet Taper Curve. 
Premièrement, ajoutez un nouvel Objet Curve tout en étant en mode Object et appelez-la TaperCurve. Ajustez le point de 
contrôle de gauche en l'élevant d'environ 5 unités.  
 

Maintenant, assurez vous que le contexte Edit est activé et éditez le champ TaperOb: du panneau Curve and Surface pour y 
référencer le nouvel Objet Taper Curve que nous avons appelé TaperCurve. Quand vous tapez ENTER, l'outil Taper est 
appliqué immédiatement avec les résultats montrés ci-dessous à gauche ( affichage en mode Solid à droite).  
 

  
 

Vous pouvez voir l'Objet Taper Curve en train d'être appliqué sur l'Objet extrudé (appelé Extruded object). Notez comment 
le volume du "tuyau" se rétrécit à rien pendant que l'Objet Taper Curve va de la gauche vers la droite. Si l'Objet Taper Curve 
descendait en dessous de l'axe local Y, l'intérieur du "tuyau" deviendrait son extérieur, ce qui pourrait produire à des artéfacts 
lors du rendu.  
 

Règles Importantes à prendre en considération : 
• Seule la première courbe dans le champ TaperOb: est évalué, même si vous avez plusieurs segments séparés.  
• Le retaillage débute au premier point de contrôle sur la gauche et  se déplace le long de la courbe jusqu’au dernier point de 

contrôle sur la droite.  
• Un retaillage négatif (axe local Y négatif sur l’Objet Taper Curve) est également possible, mais le rendu peut créer des 

artéfacts.  
• L’outil ajuste la largeur des extrusions normales en se basant sur une évaluation de l'Objet Taper Curve, ce qui veut dire 

que des coins bruts dans l'Objet Taper Curve ne seront pas facilement visibles.  
• Avec des courbes en mode Cyclic (c'est à dire des courbes qui se connectent pour former un Objet solide), l'Objet Taper 

Curve dans le champ TaperOb: agit sur la courbe complète (périmètre de l'Objet) et pas seulement sur la longueur de 
l'Objet, et fait varier la profondeur de l'extrusion. Dans ce type de cas, vous voulez que la hauteur relative de l'Objet Taper 
Curve (champ TaperOb:) soit la même aux deux extrémités, de sorte que le point Cyclic (l'endroit où le point final de la 
courbe se connecte avec le point de début) présente une transition lissée. 
 

  
Dans l'image ci-contre, vous pouvez voir clairement l'effet que l'Objet Curve Taper 
de gauche a sur l'Objet Curve de droite.  
 
Ici, l'Objet Curve Taper de gauche est proche du centre de l'Objet Curve et cela a 
pour résultat, un Objet Curve plus petit vers la droite.  
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Dans l'image ci-contre, un point de contrôle dans l'Objet Curve Taper de gauche a 
été éloigné du centre (déplacement vers le haut) et cela donne un résultat plus large 
sur l'Objet Curve de droite.  
 

L'Objet Curve est extrudé avec un cercle (Bezier Circle). Voyez le tutorial  
Extrusion le long d'un Chemin (Extrude Along Path) plus d'information sur 
l'extrusion de courbes.  

 

 
 

Dans l'image ci-dessous, nous voyons l'utilisation d'un Objet 
Curve Taper irrégulier ajouté à un cercle (Bezier Circle). 
 

                                   

Exemple :  
Deux Objets courbes Bezier Curve avec un biseau (Objet Bevel) 
sont 'effilés' de deux façons (Objets Taper et Taper001).  

 
5.2.9.2. L’Outil Curve Deform  
L'outil Curve Deform procure une méthode simple mais efficace pour définir une déformation 
sur un Maillage. En parentant un Objet Mesh avec un Objet Curve, vous pouvez déformer le 
Maillage le long de la courbe en déplaçant le Maillage le long, ou orthogonalement à, l'axe 
dominant.  
L'outil Curve Deform travaille sur un axe dominant X, Y ou Z. Ceci veut dire que quand vous 
déplacez votre Maillage dans la direction dominante, le Maillage se déplacera le long de la 
courbe. Déplacer le Maillage dans une direction orthogonale rapprochera ou éloignera l'Objet 
Mesh de la courbe. Le réglage par défaut dans Blender affecte l'axe Y comme axe dominant. 
Quand vous déplacez l'Objet Mesh au delà des extrémités de la courbe, l'Objet continuera à se 
déformer en se basant sur le vecteur direction des extrémités de la courbe. 
 

Conseil Pratique : Essayez de positionner votre Objet Mesh sur la courbe tout en le déplaçant. Ceci donne un meilleur 
contrôle sur la façon dont s'effectue la déformation.  
 

Interface 
Quand vous parentez un Maillage à une courbe (CTRL P),  il vous est présenté le menu Make Parent de 
l'image ci-contre. En sélectionnant, l'option Curve Deform, vous activez la fonction Curve Deform sur 
l'Objet Mesh.  

 
 

 
Le réglage de l'axe dominant est fait sur l'Objet Mesh.  Par défaut, l'axe dominant est Y 
dans Blender.  
 
Ceci peut être modifié en sélectionnant l'un des boutons Track X ,Y ou Z dans le panneau 
Anim settings (image ci-contre) dans le contexte Object (F7). 

 
 
 

Les courbes en mode Cyclic (C en mode Edit  – ce sont des courbes qui se connectent pour 
former un Objet solide) fonctionnent comme espéré, c'est à dire que la déformation de 
l'Objet se déplace en cycles le long du chemin.  
Notez que sans l'état Cyclic, un Objet se déplacera en se basant sur le vecteur de direction 
des extrémités de la courbe. 
 

Le bouton CurveStretch donne l'option de laisser l'Objet Mesh s'étirer, ou se comprimer, 
le long de la courbe entière. Cette option est disponible pour la courbe dans le panneau 
Curve and Surface du contexte Edit  (F9) (image ci-contre). 

 

 

Le bouton 3D vous permet de rendre les courbes en 3D. Cette option est disponible pour la courbe dans le panneau Curve and 
Surface du contexte Edit  (F9) (image ci-dessus). Il a les mêmes limitations que le bouton CurveFollow, c'est à dire que vous 
devez éviter une ligne droite verticale selon la direction Z pour empêcher des tremblements (flipping). 
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Exemple Simple 
 
1. Retirez l'Objet Cube par défaut de la Scène et ajoutez un Objet Monkey! 
(SHIFT A > Add > Mesh > Monkey, image ci-contre). 

 
 

 
2. Maintenant, pressez TAB  pour quitter le mode Edit . Puis, ajoutez un Objet 
Curve   (SHIFT A > Add > Curve > Bezier Curve, image ci-contre). 

 
 
 

3. Tout en étant en mode Edit , déplacez les points de contrôle de l'Objet Curve 
comme dans l'image ci-contre, puis quittez le mode Edit (TAB ). 
 
4. Sélectionnez l'Objet Monkey (RMB ), et ensuite SHIFT -sélectionnez l'Objet 
Curve, (SHIFT RMB ). Pressez CTRL P  pour ouvrir le menu Make Parent. 
Sélectionnez l'option Curve Deform. 

 
 

L'Objet Monkey devrait être positionné au début de l'Objet Curve comme sur l'image ci-contre. 
 

5. Maintenant, si vous sélectionnez l'Objet Monkey (RMB ), et que vous le déplacez  (G) dans la 
direction Y (l'axe dominant par défaut), l'Objet Monkey se déformera proprement le long de l'Objet 
Curve.  
 

Conseil Pratique : Si vous pressez MMB  tout en déplaçant l'Objet Monkey, vous contraindrez le 
mouvement à un seul axe.   

 

6. Dans l'image ci-dessous, vous pouvez voir l'Objet Monkey à différentes positions le long de l'Objet 
Curve. Pour obtenir une vue propre de la déformation, vous pouvez activer le Modificateur SubSurf 
avec Subdiv 2 et Set Smooth sur le Maillage de l'Objet Monkey.   
 

 
 

Conseil Pratique : Déplacer l'Objet Monkey dans d'autres directions que la direction dominante, créera des déformations 
curieuses. Ce sera peut être ce que vous recherchez, alors n'hésitez as à faire des expériences!  
 

5.2.9.3. Le Modificateur Curve (Deform) 
Le Modificateur Curve (Deform) fonctionne exactement comme l'outil présenté ci-dessus, avec l'exception qu'il n'est pas 
nécessaire d'établir une relation parent/enfant entre l'Objet Curve et l'Objet Mesh en train d'être déformé, et que l'effet peut 
être appliqué sur tous les types d'Objets en temps réel.  
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• OB: : Placez ici le nom de l'Objet Curve pour que le Modificateur soit 
appliqué.  

• VGroup:  : Le nom d'un groupe de vertices optionnel qui permet de contrôler 
plus finement la déformation.  

• X, Y, Z, -X, -Y, -Z : Ces boutons permettent de régler l'axe le long duquel la 
courbe déforme. 

 
 

 

Exemple 
Cet exemple montre un Maillage, le support du film, qui est déformé par le 
Modificateur Curve. L'Objet Curve est la ligne noire unique qui défile à travers les 
roues.  Pour animer le film passant à travers les roues, il suffit de draguer le Maillage du 
film le long de l'axe de l'Objet Curve!  
  
 
 

 


